Benutzer-Werkzeuge

Webseiten-Werkzeuge


Übersetzungen dieser Seite:
de:koarrl_alzopenwrt

koarrl: Alzheim-OpenWRT

(last edit: 2019-02-20)

* Kaufen

* Auspacken .. Anm.: „~~factory.bin“ ist für erstmaliges Einspielen über TP-Link-Original-FW, später „~~update.bin“ nehmen.

Factory-Image:http://downloads.openwrt.org/snapshots/trunk/ar71xx/openwrt-ar71xx-generic-tl-wr710n-v1-squashfs-factory.bin
Update-Image:http://downloads.openwrt.org/snapshots/trunk/ar71xx/openwrt-ar71xx-generic-tl-wr710n-v1-squashfs-sysupgrade.bin

UNBEDINGT vor Einspielen Binärfiles auf korrekte MD5-Sum prüfen!!
Diese ändert sich so oft wie der Inhalt der Images (snapshots-unstable).
Also - siehe hier: http://downloads.openwrt.org/snapshots/trunk/ar71xx/md5sums
Schnelle Prüfung:

cat md5sums|grep wr710n-v1-squashfs

ergibt etwa dieses (Stand 2015-01-15):

91a7b64e820938f36c61bb56d5e6b2cf *openwrt-ar71xx-generic-tl-wr710n-v1-squashfs-factory.bin
3bdf42108a00005c64c6750a36b73b91 *openwrt-ar71xx-generic-tl-wr710n-v1-squashfs-sysupgrade.bin

* Anschließen (Netz und LAN)

* am eigenen Rechner umstellen:

ifconfig eth0 192.168.0.2

* Default-Adresse des Original-TPlink-Gerätes 192.168.0.254 ansurfen (admin:admin) … FirmwareUpgrade … „~~factory.bin“ einspielen & warten …

* am eigenen Rechner umstellen:

ifconfig eth0 192.168.1.2

* Gerät rebootet sodann (LED aus-blink-ein) und ist ab nun über telnet 192.168.1.1 wieder erreichbar –> passwd ändern!

* Weiter nun über ssh-Verbindung als root, zuerst nerdig mit vi arbeiten :-P

vi /etc/config/network

Das File sollte dann etwa so aussehen:

  config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd48:16db:01b6::/48'

config interface 'lan'
        option ifname 'eth1'
        option force_link '1'
        option proto 'static'
        option ipaddr '192.168.1.254'
        option netmask '255.255.255.0'
        option gateway '192.168.1.1'
        option dns '8.8.8.8'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth0'
        option proto 'dhcpv6'

Das vi-microHOWTO hier:

am Anfang ... mit "a" in den Einfügemodus wechseln!
am Ende ......ESC : w q ENTER

Anm.: /etc/resolv.conf ist verlinkt auf /tmp/… –> Änderung unnötig!

Kiste rebooten, rootshell per ssh anwerfen

Paketliste aktualisieren, wichtige Tools, Webinterface dazuinstallieren:

opkg update
opkg install mc
opkg install iputils-traceroute6
opkg install luci-ssl
opkg install luci-theme-openwrt
opkg install kmod-usb-storage

Um den Webserver sofort zu starten:

/etc/init.d/uhttpd start

Bzw. - um den Webserver zukünftig immer zu starten:

/etc/init.d/uhttpd enable

Reparatur nach Kaputtkonfiguration

Keine Panik, Gehäuse öffnen und tftp-boot per SIO ist der allerletzte Weg.
Einfacher geht es so (siehe auch http://wiki.openwrt.org/de/doc/howto/generic.failsafe ):

Kaputten Router anstecken, während LED langsam blinkt, Key drücken → LED blinkt schnell!

Nun direkt am LAN-Port(eth1) des Routers einen Rechner mit IP 192.168.1.2 anstecken ..

$ telnet 192.168.1.1

.. verbindet sich, der Router stellt eine Rootshell ohne PW im failsafe-Modus bereit!

Dieses script löscht alles Verkonfigurierte:

# firstboot

Danach - JFFS-Partition r/w mounten etc.:

# mount_root

Jetzt erst kann /etc/config/network sinnvoll (mit vi) modifiziert werden.

Abschließend unbedingt :

# reboot -f

Nächster login erfolgt zunächst wieder per telnet!

# passwd 

Jetzt ein Root-PW setzen, wieder rebooten, ab dann login nur noch per ssh!!

Nun weiter: Herstellen einer Internetverbindung, damit Pakete nachgeladen werden können. Im Beispiel hat der Router jetzt die IP 192.168.3.190 und 192.168.3.1 ist ein funktionierender Gateway.

# echo "nameserver 8.8.8.8" > /etc/resolv.conf
# route add default gw 192.168.3.1 metric 1

Nur als Referenz:

opkg list-installed

.. zeigt die aktuelle Paketliste an, wie etwa diese brauchbare hier:

base-files 			156-r43381
busybox 			1.22.1-4
dnsmasq 			2.72-1
dropbear 			2014.65-2
firewall 			2014-09-19
fstools 			2014-11-24-d42c64d78f4224dd0a0a4effc0754215f2af3851
glib2 				2.41.1-2
hostapd-common 			2014-10-25-1
ip6tables 			1.4.21-1
iptables 			1.4.21-1
iw 				3.15-1
iwinfo 				2014-10-27.1-d5dc3d0605f76fbbbad005d998497e53a236aeda
jshn 				2014-11-23-f09ae76445e32511433fdab0a1bcda73aa84986d
jsonfilter 			2014-06-19-cdc760c58077f44fc40adbbe41e1556a67c1b9a9
kernel 				3.14.18-1-8325ae478fc877c973d123f5191cb75c
kmod-ath 			3.14.18+2014-11-04-1
kmod-ath9k 			3.14.18+2014-11-04-1
kmod-ath9k-common 		3.14.18+2014-11-04-1
kmod-cfg80211 			3.14.18+2014-11-04-1
kmod-crypto-aes 		3.14.18-1
kmod-crypto-arc4 		3.14.18-1
kmod-crypto-core 		3.14.18-1
kmod-gpio-button-hotplug 	3.14.18-1
kmod-ip6tables 			3.14.18-1
kmod-ipt-conntrack 		3.14.18-1
kmod-ipt-core 			3.14.18-1
kmod-ipt-nat 			3.14.18-1
kmod-ipv6 			3.14.18-1
kmod-ledtrig-usbdev 		3.14.18-1
kmod-lib-crc-ccitt 		3.14.18-1
kmod-mac80211 			3.14.18+2014-11-04-1
kmod-nf-conntrack 		3.14.18-1
kmod-nf-conntrack6 		3.14.18-1
kmod-nf-ipt 			3.14.18-1
kmod-nf-ipt6 			3.14.18-1
kmod-nf-nat 			3.14.18-1
kmod-nf-nathelper 		3.14.18-1
kmod-nls-base 			3.14.18-1
kmod-ppp 			3.14.18-1
kmod-pppoe 			3.14.18-1
kmod-pppox 			3.14.18-1
kmod-slhc 			3.14.18-1
kmod-usb-core 			3.14.18-1
kmod-usb-ohci 			3.14.18-1
kmod-usb2 			3.14.18-1
libattr 			20140610-1
libblobmsg-json 		2014-11-23-f09ae76445e32511433fdab0a1bcda73aa84986d
libc 				0.9.33.2-1
libffi 				3.0.13-1
libgcc 				4.8-linaro-1
libip4tc 			1.4.21-1
libip6tc 			1.4.21-1
libiwinfo 			2014-10-27.1-d5dc3d0605f76fbbbad005d998497e53a236aeda
libiwinfo-lua 			2014-10-27.1-d5dc3d0605f76fbbbad005d998497e53a236aeda
libjson-c 			0.11-2
libjson-script 			2014-11-23-f09ae76445e32511433fdab0a1bcda73aa84986d
liblua 				5.1.5-1
libncurses 			5.9-1
libnl-tiny 			0.1-3
libpolarssl 			1.3.9-1
libpthread 			0.9.33.2-1
librpc 				0.9.32-rc2-0a2179bbc0844928f2a0ec01dba93d9b5d6d41a7
libubox 			2014-11-23-f09ae76445e32511433fdab0a1bcda73aa84986d
libubus 			2014-09-17-4c4f35cf2230d70b9ddd87638ca911e8a563f2f3
libubus-lua 			2014-09-17-4c4f35cf2230d70b9ddd87638ca911e8a563f2f3
libuci 				2014-04-11.1-1
libuci-lua 			2014-04-11.1-1
libustream-polarssl 		2014-03-25-fc0b5ec804ee43c532978dd04ab0509c34baefb0
libxtables 			1.4.21-1
lua 				5.1.5-1
luci 				git-14.328.38244-91532de-1
luci-app-firewall 		git-14.328.38244-91532de-1
luci-base 			git-14.328.38244-91532de-1
luci-lib-nixio 			git-14.328.38244-91532de-1
luci-mod-admin-full 		git-14.328.38244-91532de-1
luci-proto-ppp 			git-14.328.38244-91532de-1
luci-ssl 			git-14.328.38244-91532de-1
luci-theme-bootstrap 		git-14.328.38244-91532de-1
luci-theme-openwrt 		git-14.328.38244-91532de-1
mc 				4.8.13-1.2
mtd 				20
nano 				2.3.6-1
netifd 				2014-11-23-f4ea01b966f911442c763743fd6da2401ab84bcb
odhcp6c 			2014-11-18-7e6eebbe7d3df2b86b36b2e0d6ae7ee65f642094
odhcpd 				2014-11-06-3b628005e66e90770b2757a4a02c1dee25ccb883
opkg 				9c97d5ecd795709c8584e972bfdf3aee3a5b846d-7
ppp 				2.4.7-4
ppp-mod-pppoe 			2.4.7-4
procd 				2014-11-19-02e1a4eac725aaae10c119ec2ec20d0da4a2c958
px5g 				2
swconfig 			10
terminfo 			5.9-1
uboot-envtools 			2014.07-1
ubox 				2014-10-06-0b274c16a3f9d235735a4b84215071e1e004caa9
ubus 				2014-09-17-4c4f35cf2230d70b9ddd87638ca911e8a563f2f3
ubusd 				2014-09-17-4c4f35cf2230d70b9ddd87638ca911e8a563f2f3
uci 				2014-04-11.1-1
uhttpd 				2014-10-27-fd8e5e379c23c5fbcec3e76894b839233df09067
uhttpd-mod-ubus 		2014-10-27-fd8e5e379c23c5fbcec3e76894b839233df09067
wpad-mini 			2014-10-25-1
zlib 				1.2.8-1

ACHTUNG! seit 2015-01-29 ist eine weitere Ebene im Repository.
Früher: …downloads.openwrt.org/snapshots/trunk/ar71xx/…
Jetzt: …downloads.openwrt.org/snapshots/trunk/ar71xx/generic/…

/etc/opkg.conf - neu:

dest root /                                                                                                                                     
dest ram /tmp                                                                                                                                   
lists_dir ext /var/opkg-lists                                                                                                                   
option overlay_root /overlay                                                                                                                    
src/gz chaos_calmer_base http://downloads.openwrt.org/snapshots/trunk/ar71xx/generic/packages/base                                              
src/gz chaos_calmer_luci http://downloads.openwrt.org/snapshots/trunk/ar71xx/generic/packages/luci                                              
src/gz chaos_calmer_management http://downloads.openwrt.org/snapshots/trunk/ar71xx/generic/packages/management                                  
src/gz chaos_calmer_packages http://downloads.openwrt.org/snapshots/trunk/ar71xx/generic/packages/packages                                      
src/gz chaos_calmer_routing http://downloads.openwrt.org/snapshots/trunk/ar71xx/generic/packages/routing                                        
src/gz chaos_calmer_telephony http://downloads.openwrt.org/snapshots/trunk/ar71xx/generic/packages/telephony

Schließlich kann man per Webinterface wieder die gewünschten Features des Routers einstellen.
FERTIG!

de/koarrl_alzopenwrt.txt · Zuletzt geändert: 2019/02/20 14:12 von koarrl